#63 closed defect (fixed)

Can't log in to wiki

Reported by: ejs Owned by: somebody
Priority: critical Milestone: The Hand Wavy Future
Component: service: wiki Keywords:
Cc:

Description

After the debian update the wiki is up but nobody can log in. If you try the site breaks, but clearing your cookies will resolve this.

It looks like a db issue, probably a schema change from the OS updating the version of media wiki as part of the upgrade

Change History (4)

comment:1 Changed 15 months ago by ejs

Component: miscservice: wiki
Priority: majorcritical

comment:2 Changed 15 months ago by mbooth

In the transition from Debian 9 -> 10 the default version of PHP used went from 7.0 -> 7.3

However the ansible scripts continue to request 7.0 versions of PHP deps which were not being used, and 7.3 versions of deps were missing. This is why the mediawiki schema update script failed (missing php7.3-sqlite package, we were installing php7.0-sqlite instead)

So I changed all instances of php7.0 to php7.3 in the ansible scripts to fix it: [90966788]

comment:3 Changed 15 months ago by mbooth

Resolution: fixed
Status: newresolved

comment:4 Changed 15 months ago by ejs

Status: resolvedclosed
Note: See TracTickets for help on using tickets.